Whole Network Scheduled Maintenance - May 4th 11:59 PM CT
Completed
Scheduled for May 05, 2026 at 4:59 AM – 8:59 AM
Affects
Internet Services
Under maintenance from 4:59 AM to 8:59 AM
Internet - Fiber
Under maintenance from 4:59 AM to 8:59 AM
Internet - DSL
Under maintenance from 4:59 AM to 8:59 AM
Internet - Wireless
Under maintenance from 4:59 AM to 8:59 AM
Internet - Cable
Under maintenance from 4:59 AM to 8:59 AM
Updates
Completed
May 05, 2026 at 8:59 AM
Completed
May 05, 2026 at 8:59 AM
Maintenance has completed successfully
In progress
May 05, 2026 at 4:59 AM
In progress
May 05, 2026 at 4:59 AM
Maintenance is now in progress
Planned
May 05, 2026 at 4:59 AM
Planned
May 05, 2026 at 4:59 AM
We will be performing scheduled network maintenance during the following window:
Date: May 4–May 5
Time: 11:59 PM to 4:00 AM CT
Maintenance Window: 12:00 AM to 1:00 AM CT
Scope: Network infrastructure updates
Impact: This maintenance may be service-impacting. While the primary work will occur between 12:00 AM and 1:00 AM CT, restoration activities may take up to 3 additional hours.
If your service is not restored after 1:00 AM CT, you may speed up reconnection by performing the following steps:
Wireless Customers:
Unplug the power brick for your antenna, then plug it back in
Unplug your router, then plug it back in
Fiber Customers:
Unplug your ONT and router, then plug them back in
Cable Internet Customers:
Unplug your modem and router, then plug them back in
Support: If your service is still not restored after 4am CT, please contact our office in the morning for assistance at (715)253-2111.
We appreciate your patience as we complete this work to improve network performance and reliability.