Scheduled Maintenance on Fiber & Wireless Services
Completed
Scheduled for January 29, 2025 at 5:59 AM – 7:59 AM
Affects
Internet Services
Under maintenance from 5:59 AM to 7:59 AM
Internet - Fiber
Under maintenance from 5:59 AM to 7:59 AM
Internet - Wireless
Under maintenance from 5:59 AM to 7:59 AM
Updates
Completed
January 29, 2025 at 7:59 AM
Completed
January 29, 2025 at 7:59 AM
Maintenance has completed successfully
In progress
January 29, 2025 at 5:59 AM
In progress
January 29, 2025 at 5:59 AM
Maintenance is now in progress
Planned
January 29, 2025 at 5:59 AM
Planned
January 29, 2025 at 5:59 AM
We will be performing scheduled maintenance on our wireless and fiber services on Tuesday, January 28th, from 11:59 PM to 2:00 AM. During this window, there will be an estimated downtime of 10-15 minutes. This maintenance is part of our ongoing efforts to ensure exceptional service. We appreciate your understanding and patience.