WCTV Scheduled Maintenance - July 30, 3:00 AM to 5:00 AM CT
Scheduled for July 30, 2025 at 8:00 AM – 10:00 AM
Affects
TV Services
Under maintenance from 8:00 AM to 10:00 AM
TV - Streaming - WCTV
Under maintenance from 8:00 AM to 10:00 AM
Completed
July 30, 2025 at 10:00 AMCompleted
July 30, 2025 at 10:00 AMMaintenance has completed successfully
In progress
July 30, 2025 at 8:00 AMIn progress
July 30, 2025 at 8:00 AMMaintenance is now in progress
Planned
July 30, 2025 at 8:00 AMPlanned
July 30, 2025 at 8:00 AMOur streaming provider will be performing a routine software upgrade on their equipment during the scheduled maintenance window below:
Impact to Services:
DVR services may be briefly unavailable for approximately 1 to 15 minutes across all channels.
Live play is expected to remain unaffected, with only minimal impact, if any.
No action is required on your part. We appreciate your understanding and patience as we work to maintain and improve our services.
If you have any questions or experience issues outside this window, please contact us at (715)623-0558 or (715)253-2111.