Pike Lake Maintenance Alert – April 21 @ 11:59 PM to April 22 @ 4:00 AM
Scheduled for April 22, 2025 at 4:59 AM – 9:00 AM
Affects
Internet Services
Under maintenance from 4:59 AM to 9:00 AM
Internet - Cable
Under maintenance from 4:59 AM to 9:00 AM
Completed
April 22, 2025 at 9:00 AMCompleted
April 22, 2025 at 9:00 AMMaintenance has completed successfully
In progress
April 22, 2025 at 4:59 AMIn progress
April 22, 2025 at 4:59 AMMaintenance is now in progress
Planned
April 22, 2025 at 4:59 AMPlanned
April 22, 2025 at 4:59 AMPike Lake Mac Services will undergo scheduled maintenance starting Monday, April 21 at 11:59 PM and ending Tuesday, April 22 at 4:00 AM.
We aim to keep disruptions to a minimum, but users may experience up to 2 hours of downtime during this maintenance window.
Thank you for your patience and understanding.