Scheduled for January 16, 2025 at 5:59 AM – 6:59 AM
Affects
Internet Services
Under maintenance from 5:59 AM to 6:59 AM
Internet - Fiber
Under maintenance from 5:59 AM to 6:59 AM
Updates
Completed
January 16, 2025 at 6:59 AM
Completed
January 16, 2025 at 6:59 AM
Maintenance has completed successfully
In progress
January 16, 2025 at 5:59 AM
In progress
January 16, 2025 at 5:59 AM
Maintenance is now in progress
Planned
January 16, 2025 at 5:59 AM
Planned
January 16, 2025 at 5:59 AM
Scheduled Maintenance on Fiber Network!
We apologize for the late notice, but we will be performing maintenance on our fiber network tonight, January 15, at 11:59 PM EST.
The estimated downtime is about 10-15 minutes.
If you experience any issues with your connection tomorrow morning, please give our office a call (715)253-2111 or (715)623-0558, and we’ll be happy to assist you.